Author Topic: speedometer needle bouncing  (Read 4171 times)

Offline dirrty d84

  • Newbie
  • Posts: 17
speedometer needle bouncing
« on: March 13, 2006, 12:49:00 PM »
at about 40 mph up till about 55 my speedometer needle jumps back and forth about 4 mph. is their any way to keep it from happening. it isnt that big of a deal to me, just kind of annoying. any help would be great. thanks.


Offline Mr Diesel

  • Registered Users
  • *
  • Posts: 194
  • Aaron
speedo bouncing
« Reply #1 on: March 14, 2006, 08:25:00 PM »
Either a poor connection behind the instrument cluster or the cable  needs to be lubricated.  

- Mr Diesel
'76 C30 Crew 6.2

1976 C20 Crewcab, 6.2L/SM465
1982 K30 Crewcab , 427TD/TH400
1983 C30, 6.2L/TH400
1983 K30 Crewcab 454/700R4
1986 K10 350/400. 1989 K30 cab/chassis 454/SM465

Offline 79apache

  • Newbie
  • Posts: 38
Re: speedo bouncing
« Reply #2 on: March 15, 2006, 07:11:00 AM »
I have the same problem and have tried both with no results.
If you figure this one out please post the solution.


Offline roundedline

  • Administrator
  • Senior Member
  • *****
  • Posts: 2228
Re: speedo bouncing
« Reply #3 on: March 15, 2006, 08:51:00 AM »
Did you check both ends of the cable?  Did you pull the cable out of the sleeve and lube it?

Chris Lucas
www.73-87chevytrucks.com
www.captkaoscustoms.com
Project Su
Jimmy 2WD Project


Offline 79apache

  • Newbie
  • Posts: 38
Re: speedo bouncing
« Reply #4 on: March 15, 2006, 09:32:00 PM »
Lubed it like you would a motorcycle cable.... didn't check the tranny end.. Hmmm....


Offline cooltoolguy

  • Newbie
  • Posts: 84
Re: speedo bouncing
« Reply #5 on: March 15, 2006, 09:56:00 PM »
check the speedo gears too, they could be worn.  Mine were.


Offline Texarado

  • Newbie
  • Posts: 15
Re: speedo bouncing
« Reply #6 on: March 27, 2006, 02:01:00 PM »
Mine started doing something similar. I have an 86 with cruise control. I'll be driving along about 70-75 and all of a sudden the needle will jump up to about 90-100.?? I noticed in the   catalog that there's a speed sensor. Anybody dealt with this item?