Author Topic: Starter Problems  (Read 1916 times)

Offline Johno

  • Newbie
  • Posts: 12
Starter Problems
« on: July 19, 2008, 10:05:28 AM »
 Just put new 86 350 in my 78 C20.  The first starter i used would sick and crank with key off wires were not touching.The second turned over fine but  i had a fuel leak so i shut down.Tried to restart and it cranked real slow and ground strap from engine to frame was smoking.I removed strap and tried new starter, battery fully charged but engine turns over very slow.Starter is shimmed and clearance seems to be right.Any ideas!

Offline TexasRed

  • Junior Member
  • ***
  • Posts: 639
Re: Starter Problems
« Reply #1 on: July 19, 2008, 01:57:50 PM »
is your ignition timing too advanced? I assume this engine runs fine?

Offline choptop

  • Senior Member
  • ****
  • Posts: 2476
  • Extended cab fanatic
    • conversiontrucks
Re: Starter Problems
« Reply #2 on: July 19, 2008, 04:23:43 PM »
Put the ground strap back on, and make sure all of your grounds are connected and clean
76 C10 Choptop,76 C10 Swb
85 C10, 85 K10, 85 K20,86 C10,86 K10 (all extended cabs)
86 C30 extended crewcab

Offline VileZambonie

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 17821
Re: Starter Problems
« Reply #3 on: July 19, 2008, 04:41:30 PM »
Your negative battery cable needs to go to a good clean ground on the engine block. You also need a ground from the engine to the frame and from the frame to the body. The auxiliary ground straps are necessary also and you can buy nice new braided cables cheap in the HELP! section at any auto parts store.
,                           ___ 
                         /  _ _ _\_
              ⌠ŻŻŻŻŻ'   [☼===☼]
              `()_);-;()_)--o--)_)