Author Topic: Cleaned IAC and Got A code 42.  (Read 1435 times)

Offline DnStClr

  • Senior Member
  • ****
  • Posts: 1809
Cleaned IAC and Got A code 42.
« on: November 02, 2008, 08:24:04 PM »
1987 Silverado 350 tbi- My idle stays high after it starts and warms up. I haven't put my tach on it yet. I removed  and cleaned the IAC and it didn't help the idle, but it started throwing a 42 code.(EST) When I disconnected the battery B+ and reconnected it, the code went away so I guess the spark timing is ok. What caused the code? Is it normal after removing the IAC?
Don
87 Chevy Silverado

Offline Captkaos

  • OWNER and Administrator
  • Administrator
  • Senior Member
  • *****
  • Posts: 18127
    • http://www.73-87chevytrucks.com
Re: Cleaned IAC and Got A code 42.
« Reply #1 on: November 03, 2008, 01:47:28 PM »
I would drive it to see if the code comes back.

Offline VileZambonie

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 17825
Re: Cleaned IAC and Got A code 42.
« Reply #2 on: November 03, 2008, 03:34:30 PM »
You should remove the B- not the B+. It could very well have caused an eroneous code. Spray some carb clean under the TBI and see if it effects the idle.
,                           ___ 
                         /  _ _ _\_
              ⌠ŻŻŻŻŻ'   [☼===☼]
              `()_);-;()_)--o--)_)

Offline DnStClr

  • Senior Member
  • ****
  • Posts: 1809
Re: Cleaned IAC and Got A code 42.
« Reply #3 on: November 06, 2008, 10:22:28 AM »
It hasn't returned this week so far. No change in idle when carb cleaner sprayed.
Don
87 Chevy Silverado

Offline Blue 82

  • Frequent Member
  • **
  • Posts: 281
Re: Cleaned IAC and Got A code 42.
« Reply #4 on: November 09, 2008, 07:14:08 PM »
I had a sticking TPS switch cause the same exact malfunction (hi idle)
Cleaned the IAC, checked for vacuum leaks etc, nothing....
it's was acting up for a month or so, on and off
the light finally came on (code 22)
Replaced the TPS and all is fine
82 stepside 2wd 355/th350/3.08 posi

Offline VileZambonie

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 17825
Re: Cleaned IAC and Got A code 42.
« Reply #5 on: November 10, 2008, 01:32:08 PM »
Check the TPS as suggested. If it checks out ok replace the iac motor.
,                           ___ 
                         /  _ _ _\_
              ⌠ŻŻŻŻŻ'   [☼===☼]
              `()_);-;()_)--o--)_)