Author Topic: Swap questions - 74 K10 - LQ4 6.0L  (Read 13168 times)

Offline Captkaos

  • OWNER and Administrator
  • Administrator
  • Senior Member
  • *****
  • Posts: 18125
    • http://www.73-87chevytrucks.com
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #15 on: February 07, 2015, 09:54:56 AM »
Who's harness are you using?  The one at the back of the intake isn't used on standalone setups.

Offline Colby

  • Newbie
  • Posts: 43
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #16 on: February 16, 2015, 10:32:44 AM »
I had Adam at lsxharness do my harness.  It came back with those plugs intact.

Offline Captkaos

  • OWNER and Administrator
  • Administrator
  • Senior Member
  • *****
  • Posts: 18125
    • http://www.73-87chevytrucks.com
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #17 on: February 19, 2015, 08:21:01 PM »
It is here:


If you have a stand alone harness it shouldn't use this sender.  It would be for the factory setup...

Offline Colby

  • Newbie
  • Posts: 43
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #18 on: March 06, 2015, 11:58:01 PM »
Finally got most of the loose ends tied up with the swap.  Got to fire it up for the first time tonight, runs really rough without the MAF and o2's hooked up, but it felt good to hear it run.

We are about done with the body work, hopefully primer and paint next week.

Getting Closer!




Shawn

Offline FlatBlack77

  • Junior Member
  • ***
  • Posts: 832
  • Cheap Fast Reliable - Pick 2
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #19 on: March 07, 2015, 06:59:46 AM »
looks great in that bay
"When you are a hammer, everything looks like a nail"
'77 C/10 - 350/350 mild street motor

Offline Colby

  • Newbie
  • Posts: 43
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #20 on: March 09, 2015, 11:08:31 PM »
Short video of it running!

« Last Edit: March 09, 2015, 11:10:40 PM by Colby »

Offline roundhouse

  • Senior Member
  • ****
  • Posts: 1441
  • Newbie
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #21 on: March 10, 2015, 08:42:34 AM »
Nice job

I'd get the radatior inlet swapped to the passenger side so your hose isn't five feet long


Sent from my iPhone using Tapatalk

Offline Captkaos

  • OWNER and Administrator
  • Administrator
  • Senior Member
  • *****
  • Posts: 18125
    • http://www.73-87chevytrucks.com
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #22 on: March 10, 2015, 09:38:08 PM »
The top hose is the factory hose that is on all the 99-up trucks...

Looking good!

Offline Colby

  • Newbie
  • Posts: 43
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #23 on: March 10, 2015, 11:58:55 PM »
Thanks Capt!  I appreciate all your help through this.

I bought a new radiator with the same size core as the 74', but the inlet and outlet size for the 6.0, so that I could use the new factory hoses off a yukon.

Excited, but nervous about painting it in the next week or two, but excited about starting to put it back together.

Shawn

Offline Captkaos

  • OWNER and Administrator
  • Administrator
  • Senior Member
  • *****
  • Posts: 18125
    • http://www.73-87chevytrucks.com
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #24 on: March 17, 2015, 09:36:12 PM »
Looks good.  I need to get me some of those engine covers...

Offline FlatBlack77

  • Junior Member
  • ***
  • Posts: 832
  • Cheap Fast Reliable - Pick 2
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #25 on: March 17, 2015, 10:27:00 PM »
id have that same grin lol

sounds good man
"When you are a hammer, everything looks like a nail"
'77 C/10 - 350/350 mild street motor

Offline Colby

  • Newbie
  • Posts: 43
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #26 on: April 05, 2015, 09:41:02 AM »
Hey Capt,
I got everything buttoned up in the engine bay, but the one thing I can't find is the wire for the Amp gauge?  My wiring diagram says it's supposed to be brow, but none of my brown or tan wires get any reaction on the gauge when touched to the positive terminal on the battery while running.  Any ideas?

Shawn

Offline Captkaos

  • OWNER and Administrator
  • Administrator
  • Senior Member
  • *****
  • Posts: 18125
    • http://www.73-87chevytrucks.com
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #27 on: April 10, 2015, 09:41:36 PM »
Did you check the wiring diagrams?  It has been a while since I messed with a 74 with AMP.  It is inline with the wiring.

Offline ajdmello

  • Newbie
  • Posts: 60
  • Newbie
Re: Swap questions - 74 K10 - LQ4 6.0L
« Reply #28 on: July 25, 2016, 02:23:12 PM »
Man that does look good in there!