Author Topic: rear brake problems  (Read 1421 times)

Offline drewmech

  • Newbie
  • Posts: 12
rear brake problems
« on: March 08, 2006, 03:34:00 AM »
ok i have a 76 C10 stepside 5.7 350 auto 2 wheel drive stock everything and an 87 V20 5.7 tbi th400 4 wheel drive 33 inch tires and both trucks are having the same problem rear brakes hit full lock up way to early i've taken both trucks to multiple shops and they all say that everything looks good. combination valve gone bad on me or calilbers AFU? was also thinkin a pair of proptioning valves and just remove the combination valve. any ideas comments?  


Offline bigblock73

  • Junior Member
  • ***
  • Posts: 504
  • Yeller
Re: rear brake problems
« Reply #1 on: March 08, 2006, 06:00:00 PM »
You wouldn't happen to have gear lube (or any other junk) on your shoes would you?  I had a leaking rear axle seal and this happened to me.

Jeff

'73 swb 2wd

73-87.com

Jeff

'73 swb 2wd

73-87.com

Offline Z28 c10

  • Registered Users
  • *
  • Posts: 174
Re: rear brake problems
« Reply #2 on: March 08, 2006, 07:53:00 PM »
Been having the same problem with my'81, it gets a little spooky at times but the guys at Midas say the same thing,"everything looks good". If anyone knows what to do to fix it, let us know PLEASE.


Offline Lt.Del

  • Andy aka:SgtDel
  • Senior Member
  • ****
  • Posts: 3864
  • DelbridgePhotography.com
    • www.delbridge.net
Re: rear brake problems
« Reply #3 on: March 08, 2006, 08:00:00 PM »
Gonna take a stab here....you may have air in the front lines.  this necessitates a harder push on brake pedal, locking up rear.

Bleed all lines and see what ya got.  

SgtDel