Author Topic: Cross member issue with 86 k20  (Read 1993 times)

Offline nighthawker5

  • Newbie
  • Posts: 22
  • Newbie
Cross member issue with 86 k20
« on: November 22, 2016, 09:51:48 PM »
Got my lq4 mostly in but the oil pan is hitting the cross member on the drivers side.  My mount adapter allows me to move it front and back but it's not going to clear the frame.  Any suggestions to solve this without cutting the frame?

Thank you

Offline ehjorten

  • Senior Member
  • ****
  • Posts: 1063
Re: Cross member issue with 86 k20
« Reply #1 on: November 23, 2016, 08:17:43 AM »
Off Road Design Crossmember!  I just removed my stock one on the '91 Crew Cab and installed the ORD one.  It wasn't too bad of a modification.
-Erik-
1991 V3500 - Gen V TBI 454, 4L80E, NP205, 14 bolt FF, D60, 8" Lift on 35s
1977 K20 Silverado - 350, THM350, NP203, 14 bolt FF, D44, Stock Lift on 31s
1969 Chevelle Malibu Sport Coupe - EFI350, THM350
1968 Chevrolet Step-side Pickup - 300HP L6

Offline nighthawker5

  • Newbie
  • Posts: 22
  • Newbie
Re: Cross member issue with 86 k20
« Reply #2 on: November 23, 2016, 10:12:08 PM »
I looked at their site and couldn't find it.  Is it a bolt on or do i need to fire up the tig?

Offline nighthawker5

  • Newbie
  • Posts: 22
  • Newbie
Re: Cross member issue with 86 k20
« Reply #3 on: November 27, 2016, 06:25:19 PM »
Fixed it without any modification of the cross member.  I used the icbbillet mount adapters and mounted the clamshell in the front holes. This moved the engine back far enough to clear the frame.

Offline ehjorten

  • Senior Member
  • ****
  • Posts: 1063
-Erik-
1991 V3500 - Gen V TBI 454, 4L80E, NP205, 14 bolt FF, D60, 8" Lift on 35s
1977 K20 Silverado - 350, THM350, NP203, 14 bolt FF, D44, Stock Lift on 31s
1969 Chevelle Malibu Sport Coupe - EFI350, THM350
1968 Chevrolet Step-side Pickup - 300HP L6