Author Topic: Lost ignition when cranking!  (Read 1146 times)

Offline Chevygold

  • Registered Users
  • *
  • Posts: 226
  • Newbie
Lost ignition when cranking!
« on: January 28, 2023, 02:12:16 PM »
I've just done a carb swap on my truck and now I don't seem to have ignition when cranking, spin it over on th starter and no sign of firing but as soon as I back off the key to the run position she fires up straight away!
I haven't been anywhere near the ignition switch so assume I must have dislodged a connection under the hood while I was fighting with the fuel line or the vacuum pipe to the distibutor? any suggestions as to where to look?
76 C10 383 SBC TH400
Thanks
Graham

Online bd

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 6475
Re: Lost ignition when cranking!
« Reply #1 on: January 28, 2023, 03:47:32 PM »
Does your test light illuminate when clipped to a good bare metal ground and probing the BAT terminal (pink or red wire) on the HEI distributor while an assistant cranks the engine?
Rich
It's difficult to know just how much you don't know until you know it.
In other words... if people learn by making mistakes, by now I should know just about everything!!!
87 R10 Silverado Fleetside 355 MPFI 700R4 3.42 Locker (aka Rusty, aka Mater)

Offline Chevygold

  • Registered Users
  • *
  • Posts: 226
  • Newbie
Re: Lost ignition when cranking!
« Reply #2 on: January 29, 2023, 08:27:13 AM »
Hi BD that's where I was going to start my search, maybe dislodged a connection in the distributor area, my assistant is otherwise engaged today so will try to get her out tomorrow!
Thanks
Graham

Offline Chevygold

  • Registered Users
  • *
  • Posts: 226
  • Newbie
Re: Lost ignition when cranking!
« Reply #3 on: February 19, 2023, 02:13:31 PM »
Sorry it took a while but other things have got in the way, anyway put my meter on the pink and in ignition on position get battery voltage but when cranking drops away to 0.16v so guess its the ignition switch going bad so have ordered a replacement, does start and run fine but if the contact to ignition run goes bad I'll be stuck.
I'll let you know how I get on when the new switch arrives, had a mind to see if I could get into it and clean up the contacts but wanted the replacement to hand before I try surgery!
Graham

Offline Chevygold

  • Registered Users
  • *
  • Posts: 226
  • Newbie
Re: Lost ignition when cranking!
« Reply #4 on: March 09, 2023, 01:14:03 PM »
Fitted the new ignition switch and problem cured, when I checked the original switch there was high resistance on the ignition connection when in the cranking position so pulled it apart and revealed quite a lot of dirt on the contacts. Cleaned them all with fine wet and dry then reassembled the switch then checked all the switch positions and all good so I'll refit the original and see if I can offload the replacement.
It all came apart quite easily, was a bit fiddly to get it all back together with my shaky hands! had to do it twice before I got it right but worth the effort. Didn't want to risk it without another one to hand just in case.
Graham

Online bd

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 6475
Re: Lost ignition when cranking!
« Reply #5 on: March 09, 2023, 01:27:35 PM »
Congrats!  Glad you got it sorted out.
Rich
It's difficult to know just how much you don't know until you know it.
In other words... if people learn by making mistakes, by now I should know just about everything!!!
87 R10 Silverado Fleetside 355 MPFI 700R4 3.42 Locker (aka Rusty, aka Mater)

Offline Chevygold

  • Registered Users
  • *
  • Posts: 226
  • Newbie
Re: Lost ignition when cranking!
« Reply #6 on: March 09, 2023, 02:50:08 PM »
Thanks Rich, after the carb swap and the new ignition switch it's never fired up better since I got her running so looks like the switch has been on its way out for a while!
Holley Street Avenger 670 rebuilt in my garage to standard spec, haven't had it for a drive yet so will probably need to do a bit of fine tuning with secondary springs etc. got a very slight stumble when increasing the revs slowly, could be the power valve opening?
Graham

Online bd

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 6475
Re: Lost ignition when cranking!
« Reply #7 on: March 09, 2023, 03:44:45 PM »
It could also be low float level causing late tip-in.
Rich
It's difficult to know just how much you don't know until you know it.
In other words... if people learn by making mistakes, by now I should know just about everything!!!
87 R10 Silverado Fleetside 355 MPFI 700R4 3.42 Locker (aka Rusty, aka Mater)

Offline Chevygold

  • Registered Users
  • *
  • Posts: 226
  • Newbie
Re: Lost ignition when cranking!
« Reply #8 on: March 14, 2023, 05:07:36 PM »
Just refitted my refurbished original switch and she fired right up so will try to offload the new one as I won't need one for the next 40 odd years now lol.
Graham