Author Topic: Oil pressure pegged out?  (Read 1182 times)

Offline Skunksmash

  • Senior Member
  • ****
  • Posts: 1399
Oil pressure pegged out?
« on: May 16, 2011, 07:55:23 PM »
Heh, this one is kinda funny. Never had a vehicle that had too much oil pressure. My 87 5.7L oil pressure gauge just started saying that my pressure is far above 60. As I was looking at it, no less. I was driving along and I glanced down at it, and right then it shot as far as that little needle can go. And it has stayed there ever since. So I'm thinking... I don't know... bad sending unit?

Offline screamin86

  • Junior Member
  • ***
  • Posts: 661
Re: Oil pressure pegged out?
« Reply #1 on: May 16, 2011, 08:30:28 PM »
Yep most likely bad sending unit or it came unplugged.
86 k10 lwb 4x4:350 .040 214/224 444/466 112lsa performer rpm 1406 lt's summit racing th350 2800stall
03 yukon xl:tint debadge full boltons
86 ta:lm7 hot cam boltons

Offline Skunksmash

  • Senior Member
  • ****
  • Posts: 1399
Re: Oil pressure pegged out?
« Reply #2 on: May 16, 2011, 11:46:53 PM »
Where exactly is the sending unit on these trucks? Never had to replace one.

Offline screamin86

  • Junior Member
  • ***
  • Posts: 661
Re: Oil pressure pegged out?
« Reply #3 on: May 17, 2011, 12:25:11 AM »
If your standing in front of the truck facing it the unit is on the right in the very back kinda under were the distributer sits.
86 k10 lwb 4x4:350 .040 214/224 444/466 112lsa performer rpm 1406 lt's summit racing th350 2800stall
03 yukon xl:tint debadge full boltons
86 ta:lm7 hot cam boltons

Offline topp

  • Frequent Member
  • **
  • Posts: 484
Re: Oil pressure pegged out?
« Reply #4 on: May 17, 2011, 01:00:55 AM »
For '87, there are 2- 1 for the gauge, and one for the Computer.
The one for the gauge is down by the oil filter I believe.
'87 K5 TBI 350, 4" Lift, 33X10.50/15

Offline 1980c10

  • Senior Member
  • ****
  • Posts: 1205
Re: Oil pressure pegged out?
« Reply #5 on: May 17, 2011, 07:06:33 PM »
Your wire going to the sending unit could have become grounded. If not your sending unit is most likely bad. to test this unplug the sending unit if you gauge moves replace the sender. if not look for the problem elsewhere.

Offline Skunksmash

  • Senior Member
  • ****
  • Posts: 1399
Re: Oil pressure pegged out?
« Reply #6 on: May 17, 2011, 11:30:33 PM »
Thanks that's a good idea.

Offline Skunksmash

  • Senior Member
  • ****
  • Posts: 1399
Re: Oil pressure pegged out?
« Reply #7 on: April 02, 2012, 08:27:07 PM »
Well I got both sending units on the truck replaced. Checked the wires and they seem to be ok from what I can tell. My oil pressure has now started acting... erratic. The needle will show good oil pressure for a while, like it always has. Then all the sudden it will start wiggling wildly. It wiggles fast between its usual good oil pressure, and just barely above acceptable. Then, it stops wiggling and settles about 1 notch below the medium line on the gauge. Which is not good in my opinion. Especially when the truck has always had good/high oil pressure.

I also cut my oil filter up to see if it was collapsed or had gunk in it. Since I started using oil that is supposed to shake all that stuff loose. It looked fine.

Offline VileZambonie

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 14016
Re: Oil pressure pegged out?
« Reply #8 on: April 02, 2012, 09:24:57 PM »
Sounds like a bad connection
,                           ___ 
                         /  _ _ _\_
              ⌠ŻŻŻŻŻ'   [☼===☼]
              `()_);-;()_)--o--)_)

1974 GMC

 


Facebook Comments