Author Topic: turn signals don't flash  (Read 11190 times)

Offline 85-bowtie

  • Newbie
  • Posts: 22
turn signals don't flash
« on: April 06, 2010, 01:01:47 PM »
Ok, I'll start off by saying this is on my 85 C-10, but the wiring harness that is in the truck is out of a 91 Suburban. So for the sake of argument, we are basically dealing with a 91 burb. ;D

Well, the truck has gone through a complete tear down and now is getting to the point that it will need to be taken to town for alignment and paint, so the lights need to work.

Basically all of my lights work, bulbs are good brake, tails, and turn bulbs all light up. Now here is my issue, my hazzards flash normally, but my turn signals just light up and stay solid, lacking in the flash department. lol. Any ideas where to start? The flasher is good, I swapped it for the one in my dad's Dakota tonight and it works fine in there, but still nothing in mine. Everything worked prior to tearing the truck down a year ago.

Thanks,
Nick
85 C10 RCSB/ 350 TBI/ 700R4/ 5-6 drop
05 2500HD ECSB 6.0/ 4L80E/ Blackbear tune/ leveled

I guess you could say they're stock  ::)

Offline beastie_3

  • Senior Member
  • ****
  • Posts: 3170
  • Josh
    • My truck pics
Re: turn signals don't flash
« Reply #1 on: April 06, 2010, 01:06:57 PM »
Wiggle the bulbs while they are in their sockets. Something similar happened to my truck and that's how I got it to work.

Offline 85-bowtie

  • Newbie
  • Posts: 22
Re: turn signals don't flash
« Reply #2 on: April 06, 2010, 01:20:16 PM »
I just went and wiggled every bulb and still the same.
85 C10 RCSB/ 350 TBI/ 700R4/ 5-6 drop
05 2500HD ECSB 6.0/ 4L80E/ Blackbear tune/ leveled

I guess you could say they're stock  ::)

Offline jaredts

  • Senior Member
  • ****
  • Posts: 1330
Re: turn signals don't flash
« Reply #3 on: April 06, 2010, 01:49:50 PM »
Just a guess, but could you have put the wrong bulbs in?

Offline 85-bowtie

  • Newbie
  • Posts: 22
Re: turn signals don't flash
« Reply #4 on: April 06, 2010, 02:00:21 PM »
1157's in the rear for brake/turn, and 3157's in the front
85 C10 RCSB/ 350 TBI/ 700R4/ 5-6 drop
05 2500HD ECSB 6.0/ 4L80E/ Blackbear tune/ leveled

I guess you could say they're stock  ::)

Offline jaredts

  • Senior Member
  • ****
  • Posts: 1330
Re: turn signals don't flash
« Reply #5 on: April 06, 2010, 02:10:39 PM »
Are the sockets also off the '91 burb?  Check this out:  http://www.sylvania.com/ConsumerProducts/AutomotiveLighting/LampReplacementGuide/AutoLRG-Results.htm
It says 3057 in the front and 2057 in the rear.  I don't know bulb numbers too well, so I don't know what the difference is really.  Might be worth a look.
edit:  that link didn't work (sorry).  Sylvania's website will show a list though if you tell it the make/model/year.
« Last Edit: April 06, 2010, 02:27:38 PM by jaredts »

Offline Captkaos

  • OWNER and Administrator
  • Administrator
  • Senior Member
  • *****
  • Posts: 18127
    • http://www.73-87chevytrucks.com
Re: turn signals don't flash
« Reply #6 on: April 06, 2010, 02:23:57 PM »
Are all of the lighting up?  are all of them flashing?

Offline beastie_3

  • Senior Member
  • ****
  • Posts: 3170
  • Josh
    • My truck pics
Re: turn signals don't flash
« Reply #7 on: April 06, 2010, 04:37:43 PM »
Are all of the lighting up?  are all of them flashing?

+1. You had mentioned that your hazard lights work. The same lights will flash.

Offline bigwillie82

  • Newbie
  • Posts: 75
Re: turn signals don't flash
« Reply #8 on: April 06, 2010, 04:58:42 PM »
check the ground. mine did the same thing and i just ran a new ground to the frame.

Offline VileZambonie

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 17824
Re: turn signals don't flash
« Reply #9 on: April 06, 2010, 05:05:36 PM »
Did you check the hazard flasher or the turn signal flasher?
,                           ___ 
                         /  _ _ _\_
              ⌠ŻŻŻŻŻ'   [☼===☼]
              `()_);-;()_)--o--)_)

Offline 85-bowtie

  • Newbie
  • Posts: 22
Re: turn signals don't flash
« Reply #10 on: April 06, 2010, 05:50:56 PM »
Are the sockets also off the '91 burb?  Check this out:  http://www.sylvania.com/ConsumerProducts/AutomotiveLighting/LampReplacementGuide/AutoLRG-Results.htm
It says 3057 in the front and 2057 in the rear.  I don't know bulb numbers too well, so I don't know what the difference is really.  Might be worth a look.
edit:  that link didn't work (sorry).  Sylvania's website will show a list though if you tell it the make/model/year.

Sorry, I double checked an they are in fact 3057's in the front, but I still have the 1157's in rear. The bed section of the taillight harness is original to my 85.  All of these worked in harmony until this last tear down.

Yes all of the bulbs light up. The same bulbs flash when the hazzards are on, but just not as turn signals.

I went through my grounds last night, cleaned them up and made sure connections were tight.

Is there more than one flasher? I only found the one on the fuse panel, I assumed that they both used the same one.
85 C10 RCSB/ 350 TBI/ 700R4/ 5-6 drop
05 2500HD ECSB 6.0/ 4L80E/ Blackbear tune/ leveled

I guess you could say they're stock  ::)

Offline beastie_3

  • Senior Member
  • ****
  • Posts: 3170
  • Josh
    • My truck pics

Offline Bitzer!

  • Junior Member
  • ***
  • Posts: 906
  • Smiles per gallon
Re: turn signals don't flash
« Reply #12 on: April 08, 2010, 04:57:57 PM »

Not 100% sure but I think there is 1x relay for the indicators and 1x relay for the 4way flashers?
1979 GMC CrewCab  C20 1t
454 750 Holley,TH350, 14bolt diff fully floating
Why aren't there 8 days in a week!
A K5 rolling shell *new addition*

Offline VileZambonie

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 17824
Re: turn signals don't flash
« Reply #13 on: April 09, 2010, 05:00:06 PM »
I just re-read his original post. It's a 91 Suburban fuse panel and wiring harness. #1 check the turn signal fuse!
,                           ___ 
                         /  _ _ _\_
              ⌠ŻŻŻŻŻ'   [☼===☼]
              `()_);-;()_)--o--)_)

Offline Bitzer!

  • Junior Member
  • ***
  • Posts: 906
  • Smiles per gallon
Re: turn signals don't flash
« Reply #14 on: April 09, 2010, 05:04:20 PM »

Sorry - a '91 is too new for me!  ;)
1979 GMC CrewCab  C20 1t
454 750 Holley,TH350, 14bolt diff fully floating
Why aren't there 8 days in a week!
A K5 rolling shell *new addition*