Author Topic: Manual Hub not engaging  (Read 2355 times)

Offline srozell

  • Registered Users
  • *
  • Posts: 208
  • Newbie
    • My 1980 Chevy
Manual Hub not engaging
« on: July 05, 2017, 02:05:03 PM »
If I disassemble, then reassemble the hub, it engages and remains engaged.

When I switch the hub to "FREE" it disengages as expected.

When I switch back to "LOCK" it no longer engages, and makes a clicking sound when the wheel turns.

Inside I found wear on the following components. I've also enclosed a picture of the shop manual for reference and clarity.




Should the axle shaft sleeve and ring really be wearing on the outer clutch retaining ring?

Should I be replacing the manual hubs, or is there something else I should be doing first?
1980 K20 "Camper Special"
1969 K20 Step Side
http://myuglytruck.wordpress.com/

Offline VileZambonie

  • Global Moderator
  • Senior Member
  • *****
  • Posts: 17781
Re: Manual Hub not engaging
« Reply #1 on: July 05, 2017, 06:14:17 PM »
I would replace the locking hubs
,                           ___ 
                         /  _ _ _\_
              ⌠ŻŻŻŻŻ'   [☼===☼]
              `()_);-;()_)--o--)_)

Offline srozell

  • Registered Users
  • *
  • Posts: 208
  • Newbie
    • My 1980 Chevy
Re: Manual Hub not engaging
« Reply #2 on: July 05, 2017, 07:37:15 PM »
That's kind of what I was thinking. I cleaned the pieces up a bit, removed the burrs and such, and it engages now, but I feel like it's only a stop gap.
1980 K20 "Camper Special"
1969 K20 Step Side
http://myuglytruck.wordpress.com/

Offline ehjorten

  • Senior Member
  • ****
  • Posts: 1062
Re: Manual Hub not engaging
« Reply #3 on: July 06, 2017, 09:22:12 AM »
On that note...I understand you can't get those Spicer hubs anymore?  I have them on my 1-ton crew cab.  What is the standard for replacement...Dynatrac...Yukon?
-Erik-
1991 V3500 - Gen V TBI 454, 4L80E, NP205, 14 bolt FF, D60, 8" Lift on 35s
1977 K20 Silverado - 350, THM350, NP203, 14 bolt FF, D44, Stock Lift on 31s
1969 Chevelle Malibu Sport Coupe - EFI350, THM350
1968 Chevrolet Step-side Pickup - 300HP L6

Offline srozell

  • Registered Users
  • *
  • Posts: 208
  • Newbie
    • My 1980 Chevy
Re: Manual Hub not engaging
« Reply #4 on: July 06, 2017, 02:27:43 PM »
I was going to go with the Warn 20990. Is there any reason not to?

https://www.warn.com/truck/hubs/premium_application_chart.jsp
1980 K20 "Camper Special"
1969 K20 Step Side
http://myuglytruck.wordpress.com/

Offline jetman

  • Newbie
  • Posts: 37
  • Newbie
    • Squarebody Referance Library
Re: Manual Hub not engaging
« Reply #5 on: July 09, 2017, 03:44:13 PM »
I use 'em.  Work great, engage easily.  Don't need the spindle nut kit.

Offline srozell

  • Registered Users
  • *
  • Posts: 208
  • Newbie
    • My 1980 Chevy
Re: Manual Hub not engaging
« Reply #6 on: July 09, 2017, 07:54:32 PM »
Thanks!
1980 K20 "Camper Special"
1969 K20 Step Side
http://myuglytruck.wordpress.com/

Offline srozell

  • Registered Users
  • *
  • Posts: 208
  • Newbie
    • My 1980 Chevy
Re: Manual Hub not engaging
« Reply #7 on: July 11, 2017, 05:40:01 PM »
I installed the Warn 20990 hubs today. It generally went without a hitch. Someone had dented one of the wheel hubs a little so I needed to do some die-grinding and subsequent clean-up so the hubs would fit well, but other than that, installation was seamless.
1980 K20 "Camper Special"
1969 K20 Step Side
http://myuglytruck.wordpress.com/

Offline jetman

  • Newbie
  • Posts: 37
  • Newbie
    • Squarebody Referance Library
Re: Manual Hub not engaging
« Reply #8 on: July 11, 2017, 10:38:43 PM »
That was fast!  Should I have known you were in process I would have mentioned.
Pro Tip #482 - use a pair of pliers to bend in one end of the hub retaining snap ring.  Makes it much easier to remove the hubs for bearing service at a later date.

Offline srozell

  • Registered Users
  • *
  • Posts: 208
  • Newbie
    • My 1980 Chevy
Re: Manual Hub not engaging
« Reply #9 on: July 13, 2017, 09:58:11 PM »
I never had a problem getting them out, but it's a good tip.
1980 K20 "Camper Special"
1969 K20 Step Side
http://myuglytruck.wordpress.com/